24h購物| | PChome| 登入
2012-05-19 12:58:20| 人氣490| 回應0 | 上一篇 | 下一篇

[UVA][Stack] 120 - Stacks of Flapjacks

推薦 0 收藏 0 轉貼0 訂閱站台


 Stacks of Flapjacks 

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0


使用翻轉操作, 使得由小排到大

#include <iostream>
#include <cstdio>
#include <sstream>
using namespace std;

int main() {
    string line;
    while(getline(cin, line)) {
        stringstream sin(line);
        int A[1000], n = 0;
        int flip[1000], step = 0;
        int i, j, k, tmp;
        while(sin >> A[n])
            n++;

        printf("%d", A[0]);
        for(i = 1; i < n; i++) {
            printf(" %d", A[i]);
        }
        puts("");
        for(i = 0; i < n; i++) {
            int idx = n-i-1;
            for(j = 0; j < n-i; j++) {
                if(A[idx] < A[j])
                    idx = j;
            }
            if(idx == n-i-1)
                continue;
            if(idx) {
                flip[step++] = n-idx;
                for(j = 0, k = idx; j < k; j++, k--)
                    tmp = A[j], A[j] = A[k], A[k] = tmp;
            }
            flip[step++] = i+1;
            for(j = 0, k = n-i-1; j < k; j++, k--)
                tmp = A[j], A[j] = A[k], A[k] = tmp;
        }
        for(i = 0; i < step; i++)
            printf("%d ", flip[i]);
        puts("0");
    }
    return 0;
}

台長: Morris
人氣(490) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Math] 10427 - Naughty Sleepy Boys
此分類上一篇:[UVA][Tree] 699 - The Falling Leaves

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文