24h購物| | PChome| 登入
2013-04-20 10:28:34| 人氣1,942| 回應0 | 上一篇 | 下一篇

[UVA][窮舉] 10001 - Garden of Eden

推薦 0 收藏 0 轉貼0 訂閱站台


  Garden of Eden 

Cellular automata are mathematical idealizations of physical systems in which both space and time are discrete, and the physical quantities take on a finite set of discrete values. A cellular automaton consists of a lattice (or array), usually infinite, of discrete-valued variables. The state of such automaton is completely specified by the values of the variables at each place in the lattice. Cellular automata evolve in discrete time steps, with the value at each place (cell) being affected by the values of variables at sites in its neighborhood on the previous time step. For each automaton there is a set of rules that define its evolution.

For most cellular automata there are configurations (states) that are unreachable: no state will produce them by the application of the evolution rules. These states are called Gardens of Eden for they can only appear as initial states. As an example consider a trivial set of rules that evolve every cell into 0; for this automaton any state with non-zero cells is a Garden of Eden.

In general, finding the ancestor of a given state (or the non-existence of such ancestor) is a very hard, compute intensive, problem. For the sake of simplicity we will restrict the problem to 1-dimensional binary finite cellular automata. This is, the number of cells is a finite number, the cells are arranged in a linear fashion and their state will be either 0 or 1. To further simplify the problem each cell state will depend only on its previous state and that of its immediate neighbors (the one to the left and the one to the right).

The actual arrangement of the cells will be along a circumference, so that the last cell is next to the first.

Problem definition 

Given a circular binary cellular automaton you must find out whether a given state is a Garden of Eden or a reachable state. The cellular automaton will be described in terms of its evolution rules. For example, the table below shows the evolution rules for the automaton: Cell=XOR(Left,Right).


Left Cell Right New          
[i-1] [i] [i + 1] State          
0 0 0 0   0 * 20      
 0 0 1 1   1 * 21      
0 1 0 0   0 * 22      
0 1 1 1   1 * 23      
1 0 0 1   1 * 24      
1 0 1 0   0 * 25      
1 1 0 1   1 * 26      
1 1 1 0   0 * 27      
    90   = Automaton Identifier
 


Notice that, with the restrictions imposed to this problem, there are only 256 different automata. An identifier for each automaton can be generated by taking the New State vector and interpreting it as a binary number (as shown in the table). For instance, the automaton in the table has identifier 90. The Identity automaton (every state evolves to itself) has identifier 204.

Input 

The input will consist of several test cases. Each input case will describe, in a single line, a cellular automaton and a state. The first item in the line will be the identifier of the cellular automaton you must work with. The second item in the line will be a positive integer N ( $4 le N le 32$) indicating the number of cells for this test case. Finally, the third item in the line will be a state represented by a string of exactly N zeros and ones. Your program must keep reading lines until the end of the input (end of file).

Output 

If an input case describes a Garden of Eden you must output the string GARDEN OF EDEN. If the input does not describe a Garden of Eden (it is a reachable state) you must output the string REACHABLE.

The output for each test case must be in a different line.

Sample Input 

0 4 1111
204 5 10101
255 6 000000
154 16 1000000000000000

Sample Sample Output 

GARDEN OF EDEN
REACHABLE
GARDEN OF EDEN
GARDEN OF EDEN



Miguel Revilla
2000-08-21

題目真的很難看懂,不過把它想成生命遊戲就好。

這一格如果是 1 左跟右分別為多少,根據 function 之後,下一時刻會變成什麼樣子(NewState)。
由於是環狀的細胞列,因此頭尾相接。因此下一時刻會得到新的細胞環狀。

而給定的 ID 只不過是 function 的壓縮代碼,還原一下得到 function 即可。

題目要問的是,有沒有存在一個 input 下一時刻會得到輸入的 target。
因此開始窮舉,先設法得到 target[0] = func(?),因此就會知道 input[-1], input[0], input[1],
當要得到 target[i] 時必須符合之前得到的 input[i-1], input[i], 然後會得到 input[i+1] ...
最後再回頭檢查環狀首尾是否可以得到 target[]

補充一下 func(input[i-1], input[i], input[i+1]) = target[i]

#include <stdio.h>
int func[8];
int target[50], origin[50];
int ID, n, found;
char s[50];
void dfs(int idx) {
    if(found)   return;
    int i, j;
    if(idx == n-1) {
        i = (origin[n-2]<<2)|(origin[n-1]<<1)|(origin[0]<<0);
        j = (origin[n-1]<<2)|(origin[0]<<1)|(origin[1]<<0);
        if(target[idx] == func[i] && target[0] == func[j])
            found = 1;
        return;
    }
    for(i = 0; i < 8; i++) {
        if(func[i] == target[idx] && ((i>>2)&1) == origin[idx-1] && ((i>>1)&1) == origin[idx]) {
            origin[idx+1] = (i>>0)&1;
            dfs(idx+1);
            if(found)   return;
        }
    }
}
int main() {
    int i;
    while(scanf("%d %d %s", &ID, &n, s) == 3) {
        for(i = 0; i < n; i++)
            target[i] = s[i]-'0';
        for(i = 0; i < 8; i++)
            func[i] = (ID>>i)&1;
        found = 0;
        for(i = 0; i < 8; i++) {
            if(func[i] == target[0]) {
                origin[0] = (i>>1)&1;
                origin[1] = (i>>0)&1;
                dfs(1);
            }
        }
        if(found)
            puts("REACHABLE");
        else
            puts("GARDEN OF EDEN");
    }
    return 0;
}

台長: Morris
人氣(1,942) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][三角形交集][線段交點、射線法、凸包] 11122 - Tri Tri
此分類上一篇:[UVA][dp] 10888 - Warehouse

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文