24h購物| | PChome| 登入
2013-02-28 09:06:06| 人氣2,051| 回應0 | 上一篇 | 下一篇

[UVA][queue] 12100 - Printer Queue

推薦 0 收藏 0 轉貼0 訂閱站台

Problem F - Printer Queue

Time limit: 1 second

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows.

  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, then move J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).

In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n-1). The first position in the queue is number 0, the second is number 1, and so on.
  • One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5
The 2006 ACM Northwestern European Programming Contest

檢查是否有優先權高的仍在 queue 中,由於優先權不過 1-9 計數一下就好了。
效率不會太差。

#include <stdio.h>
#include <queue>
using namespace std;
int main() {
    int t, n, m, x, i, j, v, idx;
    scanf("%d", &t);
    while(t--) {
        scanf("%d %d", &n, &m);
        queue<int> Qv, Qidx;
        int inQ[10] = {};
        for(i = 0; i < n; i++) {
            scanf("%d", &x);
            Qv.push(x), Qidx.push(i);
            inQ[x]++;
        }
        int time = 0;
        while(true) {
            v = Qv.front(), Qv.pop();
            idx = Qidx.front(), Qidx.pop();

            int canPop(1);
            for(i = v+1; i < 10; i++)
                canPop &= inQ[i] == 0;
            if(canPop) {
                time++;
                if(idx == m) {
                    printf("%d\n", time);
                    break;
                }
                inQ[v]--;
            } else {
                Qv.push(v), Qidx.push(idx);
            }
        }
    }
    return 0;
}

台長: Morris
人氣(2,051) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][dp&greedy] 12172 - Matchsticks
此分類上一篇:[UVA][遞迴] 12208 - How Many Ones Needed?

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文