24h購物| | PChome| 登入
2012-03-16 17:25:53| 人氣2,742| 回應15 | 上一篇 | 下一篇

[UVA][BFS] 572 - Oil Deposits

推薦 0 收藏 0 轉貼0 訂閱站台

  Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 le m le 100$ and $1 le n le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2


#include <stdio.h>
#include <stdlib.h>
int main() {
    int n, m, i, j, k, l;
    char map[101][101];
    while(scanf("%d %d", &n, &m) == 2) {
        if(n == 0 && m == 0)
            break;
        for(i = 0; i < n; i++)
            scanf("%s", &map[i]);
        int ans = 0, x, y, tx, ty;
        int Dx[8] = {0, 0,1, 1,1,-1,-1,-1};
        int Dy[8] = {1,-1,0,-1,1,0,-1,1};
        for(i = 0; i < n; i++) {
            for(j = 0; j < m; j++) {
                if(map[i][j] == '@') {
                    ans++;
                    int Q[10000][2], Qidx = 0;
                    Q[0][0] = i, Q[0][1] = j;
                    map[i][j] = '*';
                    for(k = 0; k <= Qidx; k++) {
                        x = Q[k][0], y = Q[k][1];
                        for(l = 0; l < 8; l++) {
                            tx = x + Dx[l], ty = y + Dy[l];
                            if(tx >= 0 && tx < n && ty >= 0 && ty < m) {
                                if(map[tx][ty] == '@') {
                                    Qidx++;
                                    Q[Qidx][0] = tx;
                                    Q[Qidx][1] = ty;
                                    map[tx][ty] = '*';
                                }
                            }
                        }
                    }
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

台長: Morris
人氣(2,742) | 回應(15)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][D&C] 10006 - Carmichael Numbers
此分類上一篇:[UVA][ConvexHull] 218 - Moth Eradication

xem phim online
我在摸索我存在的意義
2017-10-03 14:49:28
www office com setup
私はあなたが何をしようとしている、お寄せいただきありがとうございます。私はGoogleを介してこのウェブサイトを見つけることは幸運です。
2018-05-18 20:28:05
office.com/setup
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you.
2018-08-01 15:39:35
norton tech support
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://activateantivirus.com/support-for-norton/
2018-08-03 00:33:55
norton tech support
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://activateantivirus.com/support-for-norton/
2018-08-08 14:03:50
mcafee com activate
This is actually very informative article – not like most of what I see online. Thanks for the free share and looking forward reading your updates! simply wow!
2018-08-15 00:15:24
www.office.com/setup
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://setupoffize.com/office-com-setup/
2018-08-31 01:40:01
office.com/setup
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://install-office.com/setup/
2018-09-04 01:14:18
norton.com/setup
Great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://activateantivirus.com/norton-com-setup/
2018-09-09 01:46:18
mcafee com activate
Mcafee帮助 - Mcafee激活的分步指南,在线下载和完成安装。如果您遇到激活或设置Mcafee产品的问题,我们将提供独立的支持服务。
2018-09-15 13:20:30
norton tech support
I really enjoyed reading your article. I found this as an informative and interesting post, so I think it is very useful and knowledgeable. I would like to thank you for the effort you have made in writing this article… we provide support for Norton at https://activateantivirus.com/support-for-norton/
2018-09-16 22:51:53
www.office.com/setup
I really enjoyed reading your article. I found this as an informative and interesting post, so I think it is very useful and knowledgeable. I would like to thank you for the effort you have made in writing this article… We provide activation and support for Ms Office, office365. http://setupoffize.com/office-com-setup/.
2018-09-21 22:04:52
www.mcafee.com/activate
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://mcafeecomactivatenow.xyz/
2018-10-02 01:53:48
mcafee activate
Great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://mcafeecomactivatenow.xyz/
2018-10-21 05:45:41
www.office.com/setup
Positive site, where did u come up with the information on this posting? I have read a few of the articles on your website now, and I really like your style. Thanks a million and please keep up the effective work.
2018-11-05 13:35:53
是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文