24h購物| | PChome| 登入
2012-10-13 12:13:18| 人氣1,219| 回應0 | 上一篇 | 下一篇

[UVA][dp][2DLIS] 1196 - Tiling Up Blocks

推薦 0 收藏 0 轉貼0 訂閱站台

Michael The Kid receives an interesting game set from his grandparent as his birthday gift. Inside the game set box, there are n tiling blocks and each block has a form as follows:

epsfbox{p2815.eps}

Each tiling block is associated with two parameters (l, m), meaning that the upper face of the block is packed with l protruding knobs on the left and m protruding knobs on the middle. Correspondingly, the bottom face of an (l, m)-block is carved with l caving dens on the left and m dens on the middle.

It is easily seen that an (l, m)-block can be tiled upon another (l, m)-block. However, this is not the only way for us to tile up the blocks. Actually, an (l, m)-block can be tiled upon another (l', m')-block if and only if l $ geq$ l' and m $ geq$ m' .

Now the puzzle that Michael wants to solve is to decide what is the tallest tiling blocks he can make out of the given n blocks within his game box. In other words, you are given a collection of n blocks B = {b1, b2,..., bn} and each block bi is associated with two parameters (li, mi). The objective of the problem is to decide the number of tallest tiling blocks made from B.

Input 

Several sets of tiling blocks. The inputs are just a list of integers. For each set of tiling blocks, the first integer n represents the number of blocks within the game box. Following n, there will be n lines specifying parameters of blocks in B; each line contains exactly two integers, representing left and middle parameters of the i-th block, namely, li and mi. In other words, a game box is just a collection of n blocks B = {b1, b2,..., bn} and each block bi is associated with two parameters (li, mi).

Note that n can be as large as 10000 and li and mi are in the range from 1 to 100. An integer n = 0 (zero) signifies the end of input.

Output 

For each set of tiling blocks B, output the number of the tallest tiling blocks can be made out of B. Output a single star `*' to signify the end of outputs.

Sample Input 

3
3 2
1 1
2 3
5
4 2
2 4
3 3
1 1
5 5
0

Sample Output 

2
3
*

二維的沒辦法換成一維的 nlogn 的方法去做,因此用了以下的方法去做。
O(100*100)

#include <stdio.h>
#define max(x,y) ((x)>(y)?(x):(y))
int main() {
int n;
while(scanf("%d", &n) == 1 && n) {
int l, m, i, j;
int dp[101][101] = {}, used[101][101] = {};
for(i = 0; i < n; i++)
scanf("%d %d", &l, &m), used[l][m]++;
for(i = 1; i <= 100; i++) {
for(j = 1; j <= 100; j++) {
dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
dp[i][j] += used[i][j];
}
}
printf("%d\n", dp[100][100]);
}
puts("*");
return 0;
}

台長: Morris
人氣(1,219) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][GCD] 10673 - Play with Floor and Ceil
此分類上一篇:[UVA][數學] 10680 - LCM

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文