24h購物| | PChome| 登入
2012-07-09 20:13:01| 人氣628| 回應0 | 上一篇 | 下一篇

[UVA][Java] 10494 - If We Were a Child Again

推薦 0 收藏 0 轉貼0 訂閱站台

Problem C
If We Were a Child Again

Input: standard input
Output: standard output

Time Limit: 7 seconds

 

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

 

 

The Problem

 

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

 

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

 

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

 

 
Output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

 

 
 
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

 

 

 

 

 
 
Sample Output

1

9

1

2147483646

 

 

 

 



import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        BigInteger a, b;
        while(cin.hasNext()) {
            a = new BigInteger(cin.next());
            char tmp = cin.next().charAt(0);
            b = new BigInteger(cin.next());
            String res = "";
            switch(tmp) {
            case '+':
                res = a.add(b).toString();
                break;
            case '-':
                res = a.subtract(b).toString();
                break;
            case '*':
                res = a.multiply(b).toString();
                break;
            case '/':
                res = a.divide(b).toString();
                break;
            case '%':
                res = a.mod(b).toString();
            }
            System.out.println(res);
        }
    }
}

台長: Morris
人氣(628) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Java] 10669 - Three powers
此分類上一篇:[UVA][Java] 10198 - Counting

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文