24h購物| | PChome| 登入
2012-06-22 12:59:44| 人氣854| 回應0 | 上一篇 | 下一篇

[UVA] 713 - Adding Reversed Numbers

推薦 0 收藏 0 轉貼0 訂閱站台


  Adding Reversed Numbers 

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play.


Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.


ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add. Numbers will be at most 200 characters long.

Output 

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Sample Input 

3
24 1
4358 754
305 794

Sample Output 

34
1998
1

 


#include <stdio.h>
#include <string.h>

int main() {
    int t, i, j;
    char a[300], b[300];
    scanf("%d", &t);
    while(t--) {
        scanf("%s %s", a, b);
        int lenA = strlen(a), lenB = strlen(b);
        int sum[300] = {};
        for(i = 0; i < lenA; i++)
            sum[i] += a[i]-'0';
        for(i = 0; i < lenB; i++)
            sum[i] += b[i]-'0';
        int lenC = lenA > lenB ? lenA : lenB;
        for(j = 0; j <= lenC+1; j++) {
            sum[j+1] += sum[j]/10;
            sum[j] %= 10;
        }
        for(j = lenC+1; j >= 0; j--) {
            if(sum[j])
                break;
        }
        if(j < 0)   j++;
        i = 0;
        while(sum[i] == 0) i++;
        while(i <= j)
            printf("%d", sum[i++]);
        puts("");
    }
    return 0;
}

台長: Morris
人氣(854) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][二分圖圖色] 11080 - Place the Guards
此分類上一篇:[UVA][bfs] 924 - Spreading The News

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文