24h購物| | PChome| 登入
2011-12-16 09:22:34| 人氣2,605| 回應1 | 上一篇 | 下一篇

[UVA] 1185 - Big Number

推薦 0 收藏 0 轉貼0 訂閱站台

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input 

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 $ leq$ n $ leq$ 107 on each line.

Output 

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input 

2
10
20

Sample Output 

7
19


作法 : 數學
不過速度很慢, 也不知道要怎麼改善才好, 誰能提供個意見

#include<stdio.h>
#include<math.h>
int DP[10000001] = {0};
int main() {
int t, n, i;
double last = 0;
for(i = 1; i <= 10000000; i++) {
last += log10(i);
DP[i] = (int)last;
}
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
printf("%d\n", DP[n]+1);
}
return 0;
}

台長: Morris
人氣(2,605) | 回應(1)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 1266 - Magic Square
此分類上一篇:[UVA] 11733 - Airports

DJWS
try Stirling's formula.
2012-04-01 23:41:28
是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文