24h購物| | PChome| 登入
2012-06-01 22:07:17| 人氣2,795| 回應0 | 上一篇 | 下一篇

[UVA][Greedy] 10026 - Shoemaker's Problem

推薦 0 收藏 0 轉貼0 訂閱站台


 Shoemaker's Problem 

Shoemaker has N jobs (orders from customers) which he must make. Shoemaker can work on only one job in each day. For each ith job, it is known the integer Ti (1<=Ti<=1000), the time in days it takes the shoemaker to finish the job. For each day of delay before starting to work for the ith job, shoemaker must pay a fine of Si (1<=Si<=10000) cents. Your task is to help the shoemaker, writing a programm to find the sequence of jobs with minimal total fine.

The Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

First line of input contains an integer N (1<=N<=1000). The next N lines each contain two numbers: the time and fine of each task in order.

The Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

You programm should print the sequence of jobs with minimal fine. Each job should be represented by its number in input. All integers should be placed on only one output line and separated by one space. If multiple solutions are possible, print the first lexicographically.

Sample Input

1

4
3 4
1 1000
2 2
5 5

Sample Output

2 1 3 4

這題之前 ITSA 考過, 但是我居然使用暴搜給它狠狠地過了, 純僥倖,
這題其實只有比較兩個工作先排前面較為最好, 化簡成簡單的排序法
 
#include <stdio.h>
#include <stdlib.h>
struct work {
int s, t, v;
};
int cmp(const void *i, const void *j) {
work *a, *b;
a = (work *)i, b = (work *)j;
if(a->t*b->s != b->t*a->s)
return a->t*b->s - b->t*a->s;
return a->v - b->v;
}
int main() {
int t, i, n;
work D[1001];
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
for(i = 0; i < n; i++) {
scanf("%d %d", &D[i].t, &D[i].s);
D[i].v = i+1;
}
qsort(D, n, sizeof(work), cmp);
for(i = 0; i < n; i++) {
if(i)
putchar(' ');
printf("%d", D[i].v);
}
puts("");
if(t)
puts("");
}
return 0;
}

台長: Morris
人氣(2,795) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 10714 - Ants
此分類上一篇:[UVA] 436 - Arbitrage (II)

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文