24h購物| | PChome| 登入
2012-06-01 20:24:36| 人氣985| 回應0 | 上一篇 | 下一篇

[UVA] 436 - Arbitrage (II)

推薦 0 收藏 0 轉貼0 訂閱站台


 Arbitrage (II) 

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input Specification

The input file will contain one or more test cases. On the first line of each test case there is an integer n ( tex2html_wrap_inline34 ), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name tex2html_wrap_inline42 of a source currency, a real number tex2html_wrap_inline44 which represents the exchange rate from tex2html_wrap_inline42 to tex2html_wrap_inline48 and a name tex2html_wrap_inline48 of the destination currency. Exchanges which do not appear in the table are impossible. Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No


floyd-warshall
有些人取完對數之後, 使用加法, 這樣計算效率比較高

#include <stdio.h>
#include <string.h>
char dollar[31][50], a[50], b[50];
int encode(char s[]) {
    int i;
    for(i = 0; ; i++) {
        if(!strcmp(dollar[i], s))
            return i;
    }
}
int main() {
    int n, m, test = 0;
    int i, j, k;
    while(scanf("%d", &n) == 1 && n) {
        double map[31][31] = {}, f;

        for(i = 0; i < n; i++)
            scanf("%s", dollar[i]), map[i][i] = 1;
        scanf("%d", &m);

        while(m--) {
            scanf("%s %lf %s", a, &f, b);
            i = encode(a);
            j = encode(b);
            map[i][j] = f;
        }
        for(k = 0; k < n; k++) {
            for(i = 0; i < n; i++) {
                for(j = 0; j < n; j++) {
                    if(map[i][j] < map[i][k]*map[k][j])
                        map[i][j] = map[i][k]*map[k][j];
                }
            }
        }
        int flag = 0;
        for(i = 0; i < n; i++)
            if(map[i][i] > 1 + 1e-5)
                flag = 1;
        printf("Case %d: %s\n", ++test, flag ? "Yes" : "No");
    }
    return 0;
}

台長: Morris
人氣(985) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Greedy] 10026 - Shoemaker's Problem
此分類上一篇:[UVA][floyd-warshall][difficult] 125 - Numbering Paths

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文