24h購物| | PChome| 登入
2012-05-26 18:17:29| 人氣1,730| 回應0 | 上一篇 | 下一篇

[UVA][Math] 10161 - Ant on a Chessboard

推薦 0 收藏 0 轉貼0 訂閱站台


 

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

 

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

 

 

Sample Output

2 3

5 4

1 5


算好 中間(1,3,7,13,21 ...)的就容易多了, 之後再去扣

#include <stdio.h>
#include <stdlib.h>
int main() {
    int n;
    while(scanf("%d", &n) == 1 && n) {
        int m, i, j = 1;
        for(m = 1, i = 2, j = 1; ; m += i, i += 2, j++) {
            if(abs(m-n) < j)
                break;
        }
        int x = j, y = j;
        if(j&1) {
            if(n > m)
                x -= (n-m);
            else
                y -= (m-n);
        } else {
            if(n > m)
                y -= (n-m);
            else
                x -= (m-n);
        }
        printf("%d %d\n", x, y);
    }
    return 0;
}

台長: Morris
人氣(1,730) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][LIS] 231 - Testing the CATCHER
此分類上一篇:[UVA][幾何] 438 - The Circumference of the Circle

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文