24h購物| | PChome| 登入
2012-05-25 07:32:13| 人氣943| 回應0 | 上一篇 | 下一篇

[UVA][幾何] 438 - The Circumference of the Circle

推薦 0 收藏 0 轉貼0 訂閱站台


 The Circumference of the Circle 

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.

Your job is to calculate the circumference of the unique circle that intersects all three points.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing six real numbers tex2html_wrap_inline26 , representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output Specification

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of tex2html_wrap_inline28 is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65



題目 : 給三點求外接圓周長
以前用海龍公式求面積, 現在用外積求面積,
不過核心公式還是 三角形面積 = a*b*c/(4R)

#include <stdio.h>
#include <math.h>
struct Point {
    double x, y;
};
double cross(Point &o, Point &a, Point &b) {
    return (a.x-o.x)*(b.y-o.y) - (a.y-o.y)*(b.x-o.x);
}
double dist(Point &a, Point &b) {
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main() {
    Point a, b, c;
    double R, area, pi = acos(-1);
    while(scanf("%lf %lf", &a.x, &a.y) == 2) {
        scanf("%lf %lf", &b.x, &b.y);
        scanf("%lf %lf", &c.x, &c.y);
        area = fabs(cross(a, b, c))/2;
        R = dist(a, b)*dist(b, c)*dist(c, a)/4.0/area;
        printf("%.2lf\n", 2*pi*R);
    }
    return 0;
}

台長: Morris
人氣(943) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Math] 10161 - Ant on a Chessboard
此分類上一篇:[UVA][字串處理] 392 - Polynomial Showdown

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文