24h購物| | PChome| 登入
2012-05-01 15:50:19| 人氣483| 回應0 | 上一篇 | 下一篇

[UVA][DP] 357 - Let Me Count The Ways

推薦 0 收藏 0 轉貼0 訂閱站台


 Let Me Count The Ways 

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.


零錢問題

#include <stdio.h>

int main() {
    long long DP[30001] = {};
    int m[] = {1, 5, 10, 25, 50}, i, j;
    DP[0] = 1;
    for(i = 0; i < 5; i++) {
        for(j =  m[i]; j <= 30000; j++) {
            DP[j] += DP[j-m[i]];
        }
    }
    while(scanf("%d", &i) == 1) {
        if(DP[i] != 1)
            printf("There are %lld ways to produce %d cents change.\n", DP[i], i);
        else
            printf("There is only 1 way to produce %d cents change.\n", i);
    }
    return 0;
}

台長: Morris
人氣(483) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][羅馬數字轉換] 344 - Roman Digititis
此分類上一篇:[UVA] 413 - Up and Down Sequences

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文