24h購物| | PChome| 登入
2012-04-20 16:26:26| 人氣1,137| 回應0 | 上一篇 | 下一篇

[UVA][DP] 1213 - Sum of Different Primes

推薦 0 收藏 0 轉貼0 訂閱站台

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers n and k, you should count the number of ways to express n as a sum of k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but they are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are no other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn't count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input 

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n$ le$1120 and k$ le$14.

Output 

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input 

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output 

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314

 

#include <stdio.h>
int Prime[5200], Pt;
int ans[1121][15] = {};
void sieve() {
    char mark[10000] = {};
    Pt = 0;
    int i, j;
    for(i = 2; i < 10000; i++) {
        if(mark[i] == 0) {
            Prime[Pt++] = i;
            for(j = 2; i*j < 10000; j++)
                mark[i*j] = 1;
        }
    }
}
void build() {
    ans[0][0] = 1;
    int i, j, k;
    for(i = 0; i < Pt; i++) {
        for(j = 1120; j >= Prime[i]; j--) {
            for(k = 14; k >= 1; k--)
                ans[j][k] += ans[j-Prime[i]][k-1];
        }
    }
}
int main() {
    sieve();
    build();
    int n, m;
    while(scanf("%d %d", &n, &m) == 2) {
        if(n == 0 && m == 0)
            break;
        printf("%d\n", ans[n][m]);
    }
    return 0;
}

台長: Morris
人氣(1,137) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Math] 10347 - Medians
此分類上一篇:[UVA] 1210 - Sum of Consecutive Prime Numbers

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文