24h購物| | PChome| 登入
2012-04-20 16:25:02| 人氣2,125| 回應0 | 上一篇 | 下一篇

[UVA] 1210 - Sum of Consecutive Prime Numbers

推薦 0 收藏 0 轉貼0 訂閱站台

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53 . The integer 41 has three representations 2 + 3 + 5 + 7 + 11 + 13 , 11 + 13 + 17 , and 41 . The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. Your mission is to write a program that reports the number of representations for the given positive integer.

Input 

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10000, inclusive. The end of the input is indicated by a zero.

Output 

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input 

2 
3 
17 
41
20 
666 
12 
53 
0

Sample Output 

1 
1 
2 
3 
0 
0 
1 
2


 

#include <stdio.h>
int Prime[5200], Pt;
int ans[10001] = {};
void sieve() {
    char mark[10000] = {};
    Pt = 0;
    int i, j;
    for(i = 2; i < 10000; i++) {
        if(mark[i] == 0) {
            Prime[Pt++] = i;
            for(j = 2; i*j < 10000; j++)
                mark[i*j] = 1;
        }
    }
    for(i = 0; i < Pt; i++) {
        int tmp = 0;
        for(j = i; j < Pt; j++) {
            tmp += Prime[j];
            if(tmp > 10000) break;
            ans[tmp]++;
        }
    }
}
int main() {
    sieve();
    int n;
    while(scanf("%d", &n) == 1 && n) {
        printf("%d\n", ans[n]);
    }
    return 0;
}

台長: Morris
人氣(2,125) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][DP] 1213 - Sum of Different Primes
此分類上一篇:[UVA][Greedy] 12405 - Scarecrow

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文