24h購物| | PChome| 登入
2012-04-04 19:37:49| 人氣1,511| 回應0 | 上一篇 | 下一篇

[UVA][DP] 10271 - Chopsticks

推薦 0 收藏 0 轉貼0 訂閱站台

Problem C
Chopsticks
Input: Standard Input
Output: Standard Output

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)2 is called the 'badness' of the set.

It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Sample Input

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23

Note

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
__________________________________________________________________________________________

參考 http://www.cppblog.com/rakerichard/archive/2010/02/19/108081.html

網路上蒐的另外一個用 for 迴圈跑的,
http://www.cppblog.com/syhd142/articles/118232.html
我感到疑惑, 對於 1 個人的化, 那個做法是錯誤的

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define oo 100000000
int DP[1010][5001];
int L[5001], bad[5001];
int cmp(const void *i, const void *j) {
    return *(int *)j - *(int *)i;
}
int min(int x, int y) {
    return x < y ? x : y;
}
int findDP(int k, int n) {
    if(DP[k][n] != -1)
        return DP[k][n];
    if(n < 3*k) {
        DP[k][n] = oo;
    } else if(k == 0) {
        DP[k][n] = 0;
    } else {
        DP[k][n] = min(findDP(k, n-1), findDP(k-1, n-2)+bad[n]);
    }
    return DP[k][n];
}
int main() {
    int t, n, k, i, j;
    scanf("%d", &t);
    while(t--) {
        scanf("%d %d", &k, &n);
        for(i = 1; i <= n; i++)
            scanf("%d", &L[i]);
        k += 8;
        qsort(L+1, n, sizeof(int), cmp);
        for(i = 2; i <= n; i++)
            bad[i] = (L[i]-L[i-1])*(L[i]-L[i-1]);
        for(i = 0; i <= k; i++)
            for(j = 0; j <= n; j++)
                DP[i][j] = -1;
        printf("%d\n", findDP(k, n));
    }
    return 0;
}

台長: Morris
人氣(1,511) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][DP] 10912 - Simple Minded Hashing
此分類上一篇:[UVA][DP] 10759 - Dice Throwing

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文