24h購物| | PChome| 登入
2012-03-25 16:35:49| 人氣2,637| 回應3 | 上一篇 | 下一篇

[UVA][CutPoint] 315 - Network

推薦 0 收藏 0 轉貼0 訂閱站台

 Network 

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

做法 : 求割點, DFS一次即可

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define oo 1000
int link[100][100], n;
int depth[100], low[100];
int used[100], cut;
int DFS(int node, int d, int parent) {
int i, back = oo, son = 0, tmp, flag = 0;
depth[node] = d;
for(i = 1; i <= n; i++) {
if(link[node][i] == 1) {
if(used[i] == 0) {
used[i] = 1;
tmp = DFS(i, d+1, node);
if(tmp >= d) flag = 1;
back = back < tmp ? back : tmp;
son++;
} else {
if(i != parent)
back = back < depth[i] ? back : depth[i];
}
}
}
low[node] = back;
if(node == 1) {
if(son > 1)
cut++;
} else {
cut += flag;
}
return low[node];
}
int main() {
int x, y;
char c;
while(scanf("%d", &n) == 1 && n) {
memset(link, 0, sizeof(link));
memset(depth, 0, sizeof(depth));
memset(low, 0, sizeof(low));
memset(used, 0, sizeof(used));
while(scanf("%d", &x) == 1 && x) {
while(scanf("%d%c", &y, &c) == 2) {
link[x][y] = 1;
link[y][x] = 1;
if(c == '\n') break;
}
}
used[1] = 1;
cut = 0;
DFS(1, 1, 0);
printf("%d\n", cut);
}
return 0;
}

台長: Morris
人氣(2,637) | 回應(3)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][CutEdge] 796 - Critical Links
此分類上一篇:[UVA][Math] 11314 - Hardly Hard

xem phim online
nice article
2017-10-03 13:58:52
sexe videos
Thank you
2018-06-09 23:09:51
sesso videos
Thank you..
2018-06-09 23:12:45
是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文