24h購物| | PChome| 登入
2012-03-24 09:29:13| 人氣5,026| 回應0 | 上一篇 | 下一篇

[UVA] 11150 - Cola

推薦 0 收藏 0 轉貼0 訂閱站台

You see the following special offer by the convenience store:

" A bottle of Choco Cola for every 3 empty bottles returned "

Now you decide to buy some (say N) bottles of cola from the store. You would like to know how you can get the most cola from them.

The figure below shows the case where N = 8. Method 1 is the standard way: after finishing your 8 bottles of cola, you have 8 empty bottles. Take 6 of them and you get 2 new bottles of cola. Now after drinking them you have 4 empty bottles, so you take 3 of them to get yet another new cola. Finally, you have only 2 bottles in hand, so you cannot get new cola any more. Hence, you have enjoyed 8 + 2 + 1 = 11 bottles of cola.

You can actually do better! In Method 2, you first borrow an empty bottle from your friend (?! Or the storekeeper??), then you can enjoy 8 + 3 + 1 = 12 bottles of cola! Of course, you will have to return your remaining empty bottle back to your friend.

Input

Input consists of several lines, each containing an integer N (1 ≤ N ≤ 200).

Output

For each case, your program should output the maximum number of bottles of cola you can enjoy. You may borrow empty bottles from others, but if you do that, make sure that you have enough bottles afterwards to return to them.

Sample Input

8

Sample Output

12


#include <stdio.h>
int main() {
int n;
while(scanf("%d", &n) == 1) {
int sum = n;
while(n >= 3) {
sum += n/3;
n = n/3 + n%3;
}
if(n == 2) sum++;
printf("%d\n", sum);
}
return 0;
}
 

台長: Morris
人氣(5,026) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 10057 - A mid-summer night's dream
此分類上一篇:[UVA][Sort&Search] 10125 - Sumsets

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文