24h購物| | PChome| 登入
2012-03-19 13:51:22| 人氣1,162| 回應0 | 上一篇 | 下一篇

[UVA][DP] 674 - Coin Change

推薦 0 收藏 0 轉貼0 訂閱站台

  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
13


#include <stdio.h>
int main() {
int DP[7500] = {}, M[5] = {1, 5, 10, 25, 50};
int i, j, n;
DP[0] = 1;
for(i = 0; i < 5; i++) {
for(j = M[i]; j < 7500; j++)
DP[j] += DP[j-M[i]];
}
while(scanf("%d", &n) == 1)
printf("%d\n", DP[n]);
return 0;
}
 

台長: Morris
人氣(1,162) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 621 - Secret Research
此分類上一篇:[UVA] 686 - Goldbach's Conjecture (II)

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文