24h購物| | PChome| 登入
2013-08-11 08:55:01| 人氣1,381| 回應0 | 上一篇 | 下一篇

[UVA][樹形dp] 12186 - Another Crisis

推薦 0 收藏 0 轉貼0 訂閱站台

A couple of years ago, a new world wide crisis started, leaving many people with economical problems. Some workers of a particular company are trying to ask for an increase in their salaries.

The company has a strict hierarchy, in which each employee has exactly one direct boss, with the exception of the owner of the company that has no boss. Employees that are not bosses of any other employee are called workers. The rest of the employees and the owner are called bosses.

To ask for a salary increase, a worker should file a petition to his direct boss. Of course, each boss is encouraged to try to make their subordinates happy with their current income, making the company's profit as high as possible. However, when at least T percent of its direct subordinates have filed a petition, that boss will be pressured and have no choice but to file a petition himself to his own direct boss. Each boss files at most 1 petition to his own direct boss, regardless on how many of his subordinates filed him a petition. A boss only accounts his direct subordinates (the ones that filed him a petition and the ones that didn't) to calculate the pressure percentage.

Note that a boss can have both workers and bosses as direct subordinates at the same time. Such a boss may receive petitions from both kinds of employees, and each direct subordinate, regardless of its kind, will be accounted as 1 when checking the pressure percentage.

When a petition file gets all the way up to the owner of the company, all salaries are increased. The workers' union is desperately trying to make that happen, so they need to convince many workers to file a petition to their direct boss.

Given the company's hierarchy and the parameter T, you have to find out the minimum number of workers that have to file a petition in order to make the owner receive a petition.

Input 

There are several test cases. The input for each test case is given in exactly two lines. The first line contains two integers N and T ( 1$ le$N$ le$105 , 1$ le$T$ le$100), separated by a single space. N indicates the number of employees of the company (not counting the owner) and T is the parameter described above. Each of the employees is identified by an integer between 1 and N. The owner is identified by the number 0. The second line contains a list of integers separated by single spaces. The integer Bi, at position i on this list (starting from 1), indicates the identification of the direct boss of employee i (0$ le$Bi$ le$i - 1).

The last test case is followed by a line containing two zeros separated by a single space.

Output 

For each test case output a single line containing a single integer with the minimum number of workers that need to file a petition in order to get the owner of the company to receive a petition.

Sample Input 

3 100 
0 0 0 
3 50 
0 0 0 
14 60 
0 0 1 1 2 2 2 5 7 5 7 5 7 5 
0 0

Sample Output 

3 
2 
5

題目描述:

給定長官-直接下屬關係,最底層員工為了加薪問題,打算發出聯署。
當長官的下屬中,超過 T% 的人發出請願,那麼會倍感壓力再向更上級長官發出請願,
最後傳到老闆那邊。

問最少聯署人數為多少。

題目解法:

dp[i] 表示 i 的所有下屬中,最少請願數量。

那麼 dp[i] = sigma(dp[j])

dp[j] 為前 T% 小的幾個。

#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> g[100005];
int n, t;
int dfs(int nd) {
if(g[nd].size() == 0) return 1;//leaf
vector<int> petition;
int i;
for(i = 0; i < g[nd].size(); i++)
petition.push_back(dfs(g[nd][i]));
sort(petition.begin(), petition.end());
int mn = petition.size()*t/100+(petition.size()*t%100 != 0);
int sum = 0;
for(i = 0; i < mn; i++)
sum += petition[i];
return sum;
}
int main() {
int boss, i;
while(scanf("%d %d", &n, &t) == 2 && n) {
for(i = 0; i <= n; i++)
g[i].clear();
for(i = 1; i <= n; i++) {
scanf("%d", &boss);
g[boss].push_back(i);
}
printf("%d\n", dfs(0));
}
return 0;
}
 

台長: Morris
人氣(1,381) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 教育學習(進修、留學、學術研究、教育概況) | 個人分類: UVA |
此分類下一篇:[UVA][模擬] 10114 - Loansome Car Buyer
此分類上一篇:[UVA] 11131 - Close Relatives

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文