24h購物| | PChome| 登入
2013-02-20 20:49:28| 人氣964| 回應0 | 上一篇 | 下一篇

[UVA][bfs] 12101 - Prime Path

推薦 0 收藏 0 轉貼0 訂閱站台

Problem G - Prime Path

Time limit: 1 second

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it's not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on...

Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

    1033
    1733     
    3733     
    3739     
    3779
    8779
    8179     
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
The 2006 ACM Northwestern European Programming Contest

在四位質數中,藉由一位一位地替換,問最少步數。

#include <stdio.h>
int p[10000] = {};
void sieve() {
    int i, j;
    for(i = 2; i < 10000; i++) {
        if(p[i] == 0) {
            for(j = i+i; j < 10000; j += i)
                p[j] = 1;
        }
    }
}
int main() {
    sieve();
    int a, b;
    scanf("%*d");
    while(scanf("%d %d", &a, &b) == 2) {
        int Q[9999], Qt, used[10000] = {};
        int step[10000] = {}, i, j, k, tn;
        char buf[10];
        Q[Qt = 0] = a, used[a] = 1;
        for(i = 0; i <= Qt && !used[b]; i++) {
            tn = Q[i];
            for(k = 0; k < 4; k++) {
                sprintf(buf, "%d", tn);
                for(j = '0'; j <= '9'; j++) {
                    buf[k] = j;
                    sscanf(buf, "%d", &a);
                    if(p[a] == 0 && used[a] == 0 && a >= 1000) {
                        used[a] = 1, step[a] = step[tn]+1;
                        Q[++Qt] = a;
                    }
                }
            }
        }
        if(used[b])
            printf("%d\n", step[b]);
        else
            puts("Impossible");
    }
    return 0;
}

台長: Morris
人氣(964) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][簡單多邊形面積] 10065 - Useless Tile Packers
此分類上一篇:[UVA][五則運算] 622 - Grammar Evaluation

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文