24h購物| | PChome| 登入
2013-02-15 22:19:36| 人氣385| 回應0 | 上一篇 | 下一篇

[UVA] 671 - Spell checker

推薦 0 收藏 0 轉貼0 訂閱站台


  Spell checker 

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.


If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

  • deleting of one letter from the word;

  • replacing of one letter in the word with an arbitrary letter;

  • inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input 

The first line of the input is an integer N, then a blank line followed by N datasets. There is a blank line between datasets.

The first part of each dataset contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character `#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.


The next part of the dataset contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character `#' on a separate line. There will be at most 50 words that are to be checked.


All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output 

For each dataset, write exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: `` <checked word> is correct". If the word is not correct then write this word first, then write the character `:' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Print a blank line between datasets.

Sample Input 

1

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output 

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me



Miguel Revilla
2000-05-22

#include <stdio.h>
#include <string.h>
int main() {
    char dir[10005][30], word[30];
    int t, len[10005], i, j;
    scanf("%d", &t);
    while(t--) {
        int n = 0;
        while(scanf("%s", dir[n]) == 1 && dir[n][0] != '#')
            len[n] = strlen(dir[n]), n++;
        while(scanf("%s", word) == 1 && word[0] != '#') {
            int flag = 0, wlen = strlen(word);
            for(i = 0; i < n; i++) {
                if(!strcmp(word, dir[i])) {
                    printf("%s is correct\n", word);
                    flag = 1;
                    break;
                }
            }
            if(flag)    continue;
            printf("%s:", word);
            for(i = 0; i < n; i++) {
                //delete
                int flag2 = 0, idx1, idx2;
                if(wlen == len[i]-1)
                for(j = 0; j < len[i]; j++) {
                    idx1 = 0, idx2 = 0;
                    while(word[idx1] && dir[i][idx2]) {
                        if(idx2 == j)   idx2++;
                        if(word[idx1] != dir[i][idx2])  break;
                        idx1++, idx2++;
                    }
                    if(idx2 == j)   idx2++;
                    if(!word[idx1] && !dir[i][idx2]) {
                        printf(" %s", dir[i]);
                        flag2 = 1;
                        break;
                    }
                }
                if(flag2)   continue;
                //replace
                if(wlen == len[i])
                for(j = 0; j < len[i]; j++) {
                    idx1 = 0, idx2 = 0;
                    while(word[idx1] && dir[i][idx2]) {
                        if(word[idx1] != dir[i][idx2] && idx1 != j)  break;
                        idx1++, idx2++;
                    }
                    if(!word[idx1] && !dir[i][idx2]) {
                        printf(" %s", dir[i]);
                        flag2 = 1;
                        break;
                    }
                }
                if(flag2)   continue;
                //insert
                if(wlen == len[i]+1)
                for(j = 0; j < wlen; j++) {
                    idx1 = 0, idx2 = 0;
                    while(word[idx1] && dir[i][idx2]) {
                        if(idx1 == j)   idx1++;
                        if(word[idx1] != dir[i][idx2])  break;
                        idx1++, idx2++;
                    }
                    if(idx1 == j)   idx1++;
                    if(!word[idx1] && !dir[i][idx2]) {
                        printf(" %s", dir[i]);
                        flag2 = 1;
                        break;
                    }
                }
            }
            puts("");
        }
        if(t)
            puts("");
    }
    return 0;
}

台長: Morris
人氣(385) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 327 - Evaluating Simple C Expressions
此分類上一篇:[UVA] 10500 - Robot maps

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文