24h購物| | PChome| 登入
2013-02-13 08:25:14| 人氣627| 回應0 | 上一篇 | 下一篇

[UVA][Stirling] 10061 - How many zero's and how many digits

推薦 0 收藏 0 轉貼0 訂閱站台

Problem G

How many zeros and how many digits?

Input: standard input

Output: standard output


Given a decimal integer number you will have to find out how many trailing zeros will be there in its factorial in a given number system and also you will have to find how many digits will its factorial have in a given number system? You can assume that for a b based number system there are b different symbols to denote values ranging from 0 ... b-1.


Input

There will be several lines of input. Each line makes a block. Each line will contain a decimal number N (a 20bit unsigned number) and a decimal number B (1<B<=800), which is the base of the number system you have to consider. As for example 5! = 120 (in decimal) but it is 78 in hexadecimal number system. So in Hexadecimal 5! has no trailing zeros


Output

For each line of input output in a single line how many trailing zeros will the factorial of that number have in the given number system and also how many digits will the factorial of that number have in that given number system. Separate these two numbers with a single space. You can be sure that the number of trailing zeros or the number of digits will not be greater than 2^31-1


Sample Input:

2 10
5 16
5 10

 

Sample Output:

0 1
0 2
1 3
________________________________________________________________________________________
Shahriar Manzoor
16-12-2000


//0.016
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
const double PI = 3.141592653589793239, e = 2.7182818284590452354;
double dp[100005];
int DIGIT(int N, int B) {
    if(N > 100000) {
        int res = (int)((log(sqrt(2*PI*N)) + N*log(N/e))/log(B))+1;
        return res;
    }
    return ceil(dp[N]/log(B) + 1e-10);
}
int ZERO(int N, int B) {
    int i, zero = 0xfffffff, a, b, tmp;
    for(i = 2; i <= B; i++) {
        if(B%i == 0) {
            a = 0;
            while(B%i == 0)
                a++, B /= i;
            b = 0;
            tmp = N;
            while(tmp)
                b += tmp/i, tmp /= i;
            zero = min(zero, b/a);
        }
    }
    if(zero == 0xfffffff)
        return 0;
    return zero;
}
int main() {
    int N, B, i;
    for(i = 1; i < 100005; i++)
        dp[i] = dp[i-1]+log(i);
    while(scanf("%d %d", &N, &B) == 2) {
        printf("%d %d\n", ZERO(N, B), DIGIT(N, B));
    }
    return 0;
}

台長: Morris
人氣(627) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 12571 - Brother & Sisters!
此分類上一篇:[UVA][dp][Edit distance] 164 - String Computer

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文