24h購物| | PChome| 登入
2012-06-22 17:22:15| 人氣1,478| 回應0 | 上一篇 | 下一篇

[UVA] 389 - Basically Speaking

推薦 0 收藏 0 轉貼0 訂閱站台


 Basically Speaking 

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:

  • It will have a 7-digit display.
  • Its buttons will include the capital letters A through F in addition to the digits 0 through 9.
  • It will support bases 2 through 16.

Input

The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.

Output

The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print ``ERROR'' (without the quotes) right justified in the display.

Sample Input

1111000  2 10
1111000  2 16
2102101  3 10
2102101  3 15
  12312  4  2
     1A 15  2
1234567 10 16
   ABCD 16 15

Sample Output

    120
     78
   1765
    7CA
  ERROR
  11001
 12D687
   D071


 

#include <stdio.h>
#include <string.h>
int main() {
    char s[50];
    int n, m;
    while(scanf("%s %d %d", s, &n, &m) == 3) {
        int i, l = strlen(s);
        long long dec = 0, j = 1;
        for(i = l-1; i >= 0; i--) {
            if(s[i] <= '9')
                dec += (s[i]-'0')*j;
            else
                dec += (s[i]-'A'+10)*j;
            j *= n;
        }
        int ans[60] = {}, idx = -1;
        while(dec > 0)
            ans[++idx] = dec%m, dec /= m;
        if(idx >= 7) {
            puts("  ERROR");
            continue;
        }
        if(idx < 0) idx = 0;
        for(i = 6; i > idx; i--)
            printf(" ");
        for(i = idx; i >= 0; i--)
            printf("%c", ans[i] < 10 ? ans[i]+'0' : ans[i]+'A'-10);
        puts("");
    }
    return 0;
}

台長: Morris
人氣(1,478) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][BFS] 336 - A Node Too Far
此分類上一篇:[UVA] 343 - What Base Is This?

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文