24h購物| | PChome| 登入
2012-06-02 10:47:28| 人氣2,405| 回應0 | 上一篇 | 下一篇

[UVA] 10036 - Divisibility

推薦 0 收藏 0 轉貼0 訂閱站台

Problem C: Divisibility

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions:

17+5+-21+15=16
17+5+-21-15=-14
17+5--21+15=58
17+5--21-15=28
17-5+-21+15=6
17-5+-21-15=-24
17-5--21+15=48
17-5--21-15=18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input

The first line of the input file contains a integer M indicating the number of cases to be analyzed. Then M couples of lines follow.
For each one of this couples, the first line contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.

Output

For each case in the input file, write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample input

2
4 7
17 5 -21 15
4 5
17 5 -21 15

Sample Output

Divisible
Not divisible


第一次用 set 就跑很慢, 結果最後還是用老方法

//ANSI C 0.032 s
#include <stdio.h>

#include <string.h>

int main() {
    int t, n, m, x, y, i, j;
    scanf("%d", &t);
    char ch[2][100];
    while(t--) {
        scanf("%d %d", &n, &m);
        memset(ch, 0, sizeof(ch));
        scanf("%d", &x);
        x = x%m;
        if(x < 0)   x += m;
        ch[0][x] = 1;
        char flag;
        for(i = 1, flag = 0; i < n; i++, flag ^= 1) {
            scanf("%d", &x);
            x = x%m;
            if(x < 0)   x += m;
            for(j = 0; j < m; j++) {
                if(ch[flag][j]) {
                    y = j+x;
                    if(y >= m)  y -= m;
                    ch[flag^1][y] = 1;
                    y = j-x;
                    if(y < 0)  y += m;
                    ch[flag^1][y] = 1;
                }
            }
            memset(ch[flag], 0, sizeof(ch[flag]));
        }
        int ans = ch[flag][0];
        puts(ans ? "Divisible" : "Not divisible");
    }
    return 0;
}

 

台長: Morris
人氣(2,405) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][費式] 10334 - Ray Through Glasses
此分類上一篇:[UVA][倒水問題] 571 - Jugs

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文