24h購物| | PChome| 登入
2012-05-28 21:59:00| 人氣1,406| 回應0 | 上一篇 | 下一篇

[UVA][模擬] 10116 - Robot Motion

推薦 0 收藏 0 轉貼0 訂閱站台

Problem F: Robot Motion

Source file:robot.{c, cpp, java, pas}
Input file:robot.in
Output file:robot.out

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Example input:

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Example output:

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

磨練手感

#include <stdio.h>

#include <stdlib.h>

int main() {
    int r, c, s, i, j;
    while(scanf("%d %d %d", &r, &c, &s) == 3) {
        if(r == 0 && c == 0 && s == 0)
            break;
        char map[20][20];
        for(i = 0; i < r; i++)
            scanf("%s", map[i]);
        int used[20][20] = {};
        int x = 0, y = s-1, step = 0;
        for(i = 0; i < r; i++)
            for(j = 0; j < c; j++)
                used[i][j] = -1;
        used[x][y] = 0;
        while(1) {
            step++;
            if(map[x][y] == 'N')
                x--;
            else if(map[x][y] == 'S')
                x++;
            else if(map[x][y] == 'E')
                y++;
            else
                y--;
            if(x < 0 || y < 0 || x >= r || y >= c) {
                printf("%d step(s) to exit\n", step);
                break;
            }
            if(used[x][y] != -1) {
                printf("%d step(s) before a loop of %d step(s)\n", used[x][y], step-used[x][y]);
                break;
            }
            used[x][y] = step;
        }
    }
    return 0;
}

台長: Morris
人氣(1,406) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][BFS] 352 - The Seasonal War
此分類上一篇:[UVA][BFS] 10946 - You want what filled?

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文