24h購物| | PChome| 登入
2012-05-19 07:30:32| 人氣1,373| 回應0 | 上一篇 | 下一篇

[UVA][分析字串] 587 - There's treasure everywhere!

推薦 0 收藏 0 轉貼0 訂閱站台


  There's treasure everywhere! 

Finding buried treasures is simple: all you need is a map! The pirates in the Caribbean were famous for their enormous buried treasures and their elaborate maps. The maps usually read like ``Start at the lone palm tree. Take three steps towards the forest, then seventeen step towards the small spring, . . . blahblah . . . , finally six steps toward the giant rock. Dig right here, and you will find my treasure!'' Most of these directions just boil down to taking the mentioned number of steps in one of the eight principal compass directions (depicted in the left of the figure).

Obviously, following the paths given by these maps may lead to an interesting tour of the local scenery, but if one is in a hurry, there is usually a much faster way: just march directly from your starting point to the place where the treasure is buried. Instead of taking three steps north, one step east, one step north, three steps east, two steps south and one step west (see figure), following the direct route (dashed line in figure) will result in a path of about 3.6 steps.

You are to write a program that computes the location of and distance to a buried treasure, given a `traditional' map.

Input 

The input file contains several strings, each one on a line by itself, and each one consisting of at most 200 characters. The last string will be END, signaling the end of the input. All other strings describe one treasure map each, according to the following format:

The description is a comma-separated list of pairs of lengths (positive integers less than 1000) and directions (N (north), NE (northeast), E (east), SE (southeast), S (south), SW (southwest), W (west) or NW (northwest)). For example, 3W means 3 steps to the west, and 17NE means 17 steps to the northeast. A full stop (.) terminates the description, which contains no blanks.

Output 

For every map description in the input, first print the number of the map, as shown in the sample output. Then print the absolute coordinates of the treasure, in the format ``The treasure is located at (x,y).''. The coordinate system is oriented such that the x-axis points east, and the y-axis points north. The path always starts at the origin (0,0).

On the next line print the distance to that position from the point (0,0), in the format ``The distance to the treasure is d.''. The fractional values x, y, d must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.

Sample Input 

3N,1E,1N,3E,2S,1W.
10NW.
END

Sample Output 

Map #1
The treasure is located at (3.000,2.000).
The distance to the treasure is 3.606.

Map #2
The treasure is located at (-7.071,7.071).
The distance to the treasure is 10.000.



以前的寫法得到 WA 了, 因此重寫

#include <stdio.h>
#include <math.h>
#include <string.h>
int main() {
    char str[205];
    int t = 0;
    while(gets(str)) {
        if(!strcmp(str, "END"))
            break;
        printf("Map #%d\n", ++t);
        double x = 0, y = 0, sqr2 = sqrt(2);
        int tmp = 0, i;
        for(i = 0; str[i]; i++) {
            if(str[i] >= '0' && str[i] <= '9')
                tmp = tmp*10 + str[i]-'0';
            else {
                if(str[i] == ',' || str[i] == '.')
                    continue;
                if(str[i] == 'N') {
                    if(str[i+1] == ',' || str[i+1] == '.') {
                        y += tmp;
                        i++;
                    } else if(str[i+1] == 'W') {
                        x -= tmp*sqr2/2;
                        y += tmp*sqr2/2;
                        i += 2;
                    } else {
                        x += tmp*sqr2/2;
                        y += tmp*sqr2/2;
                        i += 2;
                    }
                } else if(str[i] == 'W') {
                    x -= tmp;
                    i++;
                } else if(str[i] == 'E') {
                    x += tmp;
                    i++;
                } else {
                    if(str[i+1] == ',' || str[i+1] == '.') {
                        y -= tmp;
                        i++;
                    } else if(str[i+1] == 'W') {
                        x -= tmp*sqr2/2;
                        y -= tmp*sqr2/2;
                        i += 2;
                    } else {
                        x += tmp*sqr2/2;
                        y -= tmp*sqr2/2;
                        i += 2;
                    }
                }
                tmp = 0;
            }
        }
        printf("The treasure is located at (%.3lf,%.3lf).\n", x, y);
        printf("The distance to the treasure is %.3lf.\n\n", sqrt(x*x+y*y));
    }
    return 0;
}

台長: Morris
人氣(1,373) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Tree] 712 - S-Trees
此分類上一篇:[UVA][Math] 356 - Square Pegs And Round Holes

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文