24h購物| | PChome| 登入
2012-05-03 17:23:29| 人氣840| 回應0 | 上一篇 | 下一篇

[UVA][EASY] 445 - Marvelous Mazes

推薦 0 收藏 0 轉貼0 訂閱站台


 Marvelous Mazes 

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!

Sample Input

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X

Sample Output

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X



#include <stdio.h>

int main() {
    char str[200];
    while(gets(str)) {
        int num = 0, i, j;
        for(i = 0; str[i]; i++) {
            switch(str[i]) {
                case '0' ... '9': num += str[i]-'0';break;
                case 'b':
                    for(j = 0; j < num; j++)
                        putchar(' ');
                    num = 0;
                    break;
                case '!':
                    puts("");
                    break;
                default:
                    for(j = 0; j < num; j++)
                        putchar(str[i]);
                    num = 0;
            }
        }
        puts("");
    }
    return 0;
}

台長: Morris
人氣(840) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Normal] 490 - Rotating Sentences
此分類上一篇:[UVA][EASY] 11577 - Letter Frequency

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文