24h購物| | PChome| 登入
2012-04-15 19:52:03| 人氣533| 回應0 | 上一篇 | 下一篇

[UVA] 156 - Ananagrams

推薦 0 收藏 0 轉貼0 訂閱站台


 Ananagrams 

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon



#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <map>
using namespace std;

typedef struct {
    char s[100], ch[100];
}Word;
Word Data[1005];
int cmp(const void *i, const void *j) {
    Word *a, *b;
    a = (Word *)i, b = (Word *)j;
    return strcmp(a->s, b->s);
}
int main() {
    int i, n = 0;
    map<string, int> record;
    while(scanf("%s", &Data[n].s) == 1) {
        if(!strcmp(Data[n].s, "#"))
            break;
        for(i = 0; Data[n].s[i]; i++) {
            Data[n].ch[i] = Data[n].s[i];
            if(Data[n].ch[i] >= 'A' && Data[n].ch[i] <= 'Z')
                Data[n].ch[i] = Data[n].ch[i]-'A'+'a';
        }
        Data[n].ch[i] = '\0';
        sort(Data[n].ch, Data[n].ch+i);
        record[Data[n].ch]++;
        n++;
    }
    qsort(Data, n, sizeof(Word), cmp);
    for(i = 0; i < n; i++) {
        if(record[Data[i].ch] == 1)
            printf("%s\n", Data[i].s);
    }
    return 0;
}

台長: Morris
人氣(533) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][Negative Weight Cycle] 558 - Wormholes
此分類上一篇:[UVA] 10812 - Beat the Spread!

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文