24h購物| | PChome| 登入
2012-04-12 07:30:09| 人氣4,745| 回應0 | 上一篇 | 下一篇

[UVA][Math] 10642 - Can You Solve It?

推薦 0 收藏 0 轉貼0 訂閱站台

 

Can You Solve It?
Input: standard input
Output: standard output
Time Limit: 1 second


First take a look at the following picture. In this picture, each circle has a coordinate according to Cartesian Coordinate System. You can move from one circle to another following the path denoted by forward arrow symbols. To go from a source circle to a destination circle, total number of step(s) needed = ( number of intermediate circles you pass + 1 ). For example, to go from ( 0 , 3 ) to ( 3 , 0 ) you have to pass two intermediate circles ( 1 , 2 ) and ( 2 , 1 ). So, in this case, total number of steps needed is 2 + 1 = 3. In this problem, you are to calculate number of step(s) needed for a given source circle and a destination circle. You can assume that, it is not possible to go back using the reverse direction of the arrows.

 

Input

 

The first line in the input is the number of test cases n ( 0 < n <= 500 ) to handle. Following there are n lines each containing four integers ( 0 <= each integer <=100000 ) the first pair of which represents the coordinates of the source circle and the other represents that of the destination circle. The coordinates are listed in a form ( x , y ).

Output


For each pair of integers your program should output the case number first and then the number of step(s) to reach the destination from the source. You may assume that it is always possible to reach the destination circle from the source circle.

 

Sample Input

3
0 0 0 1
0 0 1 0
0 0 0 2

Sample Output

Case 1: 1
Case 2: 2
Case 3: 3



#include <stdio.h>
#include <stdlib.h>
long long L(long long x, long long y) {
    int sum = 0, n;
    sum = y*(y+1)/2;
    n = x;
    sum += (2*(2+y)+n-1)*n/2;
    return sum;
}
int main() {
    int n, C = 0;
    scanf("%d", &n);
    while(n--) {
        long long x1, x2, y1, y2;
        scanf("%lld %lld %lld %lld", &x1, &y1, &x2, &y2);
        long long t1, t2, Ans;
        t1 = L(x1, y1);
        t2 = L(x2, y2);
        Ans = t1-t2;
        if(Ans < 0) Ans *= -1;
        printf("Case %d: %lld\n", ++C, Ans);
    }
    return 0;
}

台長: Morris
人氣(4,745) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][LIS&LDS] 10534 - Wavio Sequence
此分類上一篇:[UVA][LIS] 437 - The Tower of Babylon

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文