24h購物| | PChome| 登入
2012-04-04 06:54:16| 人氣1,045| 回應0 | 上一篇 | 下一篇

[UVA] 10921 - Find the Telephone

推薦 0 收藏 0 轉貼0 訂閱站台

Problem B - Find the Telephone

Time Limit: 1 second

In some places is common to remember a phone number associating its digits to letters. In this way the expression MY LOVE means 69 5683. Of course there are some problems, because some phone numbers can not form a word or a phrase and the digits 1 and 0 are not associated to any letter.

Your task is to read an expression and find the corresponding phone number based on the table below. An expression is composed by the capital letters (A-Z), hyphens (-) and the numbers 1 and 0.

LettersNumber
ABC2
DEF3
GHI4
JKL5
MNO6
PQRS7
TUV8
WXYZ9

Input

The input consists of a set of expressions. Each expression is in a line by itself and has C characters, where 1 ≤ C ≤ 30. The input is terminated by enf of file (EOF).

Output

For each expression you should print the corresponding phone number.

Sample Input

1-HOME-SWEET-HOME
MY-MISERABLE-JOB

Sample Output

1-4663-79338-4663
69-647372253-562



#include <stdio.h>
int main() {
char s[27] = "22233344455566677778889999";
char str[50];
while(scanf("%s", str) == 1) {
int i;
for(i = 0; str[i]; i++) {
if(str[i] >= 'A' && str[i] <= 'Z')
printf("%c", s[str[i]-'A']);
else
printf("%c", str[i]);
}
puts("");
}
return 0;
}
 

台長: Morris
人氣(1,045) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 10970 - Big Chocolate
此分類上一篇:[UVA] 10924 - Prime Words

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文