24h購物| | PChome| 登入
2012-01-26 16:18:39| 人氣1,139| 回應0 | 上一篇 | 下一篇

[UVA] 440 - Eeny Meeny Moo

推薦 0 收藏 0 轉貼0 訂閱站台

 Eeny Meeny Moo 

Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.

To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.

Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

Input Specification

The input file will contain one or more lines, each line containing one integer n with tex2html_wrap_inline43 , representing the number of cities in the country.

Input is terminated by a value of zero (0) for n.

Output Specification

For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

Sample Input

3
4
5
6
7
8
9
10
11
12
0

Sample Output

2
5
2
4
3
11
2
3
8
16



#include <stdio.h>
#include <stdlib.h>
int Calu(int n, int k) {
    static int link[151], i, j, head, prev, last;
    for(i = 2; i < n; i++)
        link[i] = i+1;
    link[n] = 2, head = 2, prev = n;
    for(i = 1; i < n; i++) {
        for(j = 1; j < k; j++)
            prev = head, head = link[head];
        last = head;
        link[prev] = link[head];
        head = link[head];
    }
    if(last == 2)        return 1;
    return 0;
}
int main() {
    int D[150], N, count, i;
    for(i = 3; i < 150; i++) {
        count = 2;
        while(Calu(i, count) == 0)    count++;
        D[i] = count;
    }
    while(scanf("%d", &N) == 1 && N) {
        printf("%d\n", D[N]);
    }
    return 0;
}

台長: Morris
人氣(1,139) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 673 - Parentheses Balance
此分類上一篇:[UVA] 151 - Power Crisis

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文