24h購物| | PChome| 登入
2012-01-12 17:25:42| 人氣1,258| 回應0 | 上一篇 | 下一篇

[UVA] 10340 - All in All

推薦 0 收藏 0 轉貼0 訂閱站台

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


作法:Greedy

#include<stdio.h>
#define maxL 10000000
char S[maxL], T[maxL];
int main() {
    while(scanf("%s %s", &S, &T) == 2)    {
        int i, j = 0;
        for(i = 0; S[i]; i++) {
            for(; T[j]; j++)
                if(S[i] == T[j])
                    {break;}
            if(T[j] == '\0')    break;
            j++;
        }
        if(S[i] == '\0')    puts("Yes");
        else                puts("No");
    }
    return 0;
}

台長: Morris
人氣(1,258) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 11185 - Ternary
此分類上一篇:[UVA] 10220 - I Love Big Numbers !

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文