24h購物| | PChome| 登入
2012-01-12 16:44:17| 人氣1,966| 回應0 | 上一篇 | 下一篇

[UVA] 382 - Perfection

推薦 0 收藏 0 轉貼0 訂閱站台

 Perfection 

From the article Number Theory in the 1994 Microsoft Encarta: ``If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not tex2html_wrap_inline41 , b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."

Problem Statement

Given a number, determine if it is perfect, abundant, or deficient.

Input

A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.

Output

The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input

15 28 6 56 60000 22 496 0

Sample Output

PERFECTION OUTPUT
   15  DEFICIENT
   28  PERFECT
    6  PERFECT
   56  ABUNDANT
60000  ABUNDANT
   22  DEFICIENT
  496  PERFECT
END OF OUTPUT



計算因數和

#include<stdio.h>
#include<math.h>
int main() {
    int x;
    puts("PERFECTION OUTPUT");
    while(scanf("%d", &x) == 1 && x) {
        int i, j;
        int sum = 1, sq = (int)sqrt(x);
        for(i = 2; i <= sq; i++) {
            if(x%i == 0) {
                j = x/i;
                sum += i+j;
            }
        }
        printf("%5d  ", x);
        if(x == 1)             puts("DEFICIENT");
        else if(sum == x)    puts("PERFECT");
        else if(sum < x)    puts("DEFICIENT");
        else                puts("ABUNDANT");
    }
    puts("END OF OUTPUT");
    return 0;
}

台長: Morris
人氣(1,966) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 369 - Combinations
此分類上一篇:[UVA] 834 - Continued Fractions

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文