24h購物| | PChome| 登入
2011-12-03 17:39:32| 人氣1,819| 回應0 | 上一篇 | 下一篇

[UVA] 1225 - Digit Counting

推薦 0 收藏 0 轉貼0 訂閱站台

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1




#include<stdio.h>
#include<string.h>
int DP[10000][10];
void Build() {
int i, tn;
memset(DP, 0, sizeof(DP));
for(i = 1; i < 10000; i++) {
memcpy(DP[i], DP[i-1], 40);
tn = i;
while(tn) DP[i][tn%10]++, tn /= 10;
}
}
int main() {
Build();
int T, N, i;
scanf("%d", &T);
while(T--) {
scanf("%d", &N);
for(i = 0; i < 9; i++)
printf("%d ", DP[N][i]);
printf("%d\n", DP[N][i]);
}
return 0;
}
 

台長: Morris
人氣(1,819) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 11854 - Egypt
此分類上一篇:[UVA] 12342 - Tax Calculator

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文